Najnowsze wydanie Kali Linux 2018.1

Dużo się ostatnio w świecie Kali Linux dzieje. Właśnie niedawno została wydana pierwsza aktualizacja w tym roku. Zachęcamy do zapoznania się z tym, co się zmieniło w najnowszej wersji Kali 2018.1. Podstawa to oczywiście poprawki błędów jakie pojawiły się od poprzedniego wydania Kali 2017.3, następnie – nowe jądro 4.4.12 – nowe możliwości w tym dwie wyróżniające :

  • AMD Secure Memory Encryption Support – Secure Memory Encryption to funkcja, która będzie dostępna w nowszych procesorach AMD, która umożliwia automatyczne szyfrowanie i odszyfrowywanie DRAM. Dodanie tych funkcji oznacza, że ​​systemy nie będą (teoretycznie przynajmniej) podatne na ataki z zimnym startem, ponieważ nawet przy fizycznym dostępie – pamięć nie będzie czytelna.
  • Zwiększone limity pamięci – obecne (oraz starsze) 64-bitowe procesory mają limit 64 TB fizycznej przestrzeni adresowej i 256 TB wirtualnej przestrzeni adresowej (VAS), co wystarcza na bardzo długo, ale przy niektórych przypadkach sprzętu serwerowego z 64 TB pamięci, te limity zostały już osiągnięte. Na szczęście nadchodzące procesory umożliwiają stronicowanie na poziomie 5 (obsługa jest zawarta w jądrze 4.14). W skrócie oznacza to, że te nowe procesory mogą obsługiwać do 4 PB pamięci fizycznej i 128 PB pamięci wirtualnej. Dobrze czytacie – petabajty.

Nastąpiła oczywiście aktualizacja obecnych pakietów, więc jeśli już używasz Kali Linux – to zachęcamy do aktualizacji (między innymi including zaproxy, secure-socket-funneling, pixiewps, seclists, burpsuite, dbeaver oraz reaver).

Wykonanie aktualizacji posiadanej instalacji Kali:
apt update && apt full-upgrade
Jeżeli nie aktualizowaliśmy w ostatnim czasie Kali, możesz otrzymać błąd GPG dotyczący  wygaśnięcia klucza repozytorium (ED444FF07D8D0BF6). W tym przypadku wystarczy uruchomić następującą komendę jako root:
wget -q -O - https://archive.kali.org/archive-key.asc | apt-key add
Zachecamy do pobrania: https://www.kali.org/downloads/

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *